reactivate mail trigger when off - VisualCron - Forum

Community forum

PapoNL
2022-03-22T16:03:54Z
We have a job that activate email triggers that are turned off some how and turn them back on.

Everytime when we create a new job with email trigger we need to add them manual to the activation job of turned off email triggers.

is there a more efficient method for this?
PapoNL
2022-03-23T11:14:46Z
Going to test it with Time Trigger combined with 2 tasks

Task 1 email - get messages
Check inbox if contains unread mail that contains from adress %@email.com% and %subject% then save attachment to location X and leave message on server mark as read.

Task 2 email - move messages
Check inbox if contains read mail that contains from adress %@email.com% and %subject% then move mail to inbox\folder X


Tips are always welcome!


Michael Fjellström
2022-03-23T13:31:20Z
Originally Posted by: PapoNL 

Going to test it with Time Trigger combined with 2 tasks

Task 1 email - get messages
Check inbox if contains unread mail that contains from adress %@email.com% and %subject% then save attachment to location X and leave message on server mark as read.

Task 2 email - move messages
Check inbox if contains read mail that contains from adress %@email.com% and %subject% then move mail to inbox\folder X


Tips are always welcome!




They get deactivated when they lose connection to the emailserver, you could increase these values/keep "Keep connection" checked

image.png
PapoNL
2022-03-23T14:40:42Z
Originally Posted by: Michael Fjellström 

Originally Posted by: PapoNL 

Going to test it with Time Trigger combined with 2 tasks

Task 1 email - get messages
Check inbox if contains unread mail that contains from adress %@email.com% and %subject% then save attachment to location X and leave message on server mark as read.

Task 2 email - move messages
Check inbox if contains read mail that contains from adress %@email.com% and %subject% then move mail to inbox\folder X


Tips are always welcome!




They get deactivated when they lose connection to the emailserver, you could increase these values/keep "Keep connection" checked

image.png



Got an example today with the keep connection option.
Its a different one im talking about then the one above.
Sometimes the event trigger (Mail) doesnt work correctly i looks like it does nothing.
I unchecked the box keep connection and then saved the JOB and after that de mails got moved as it should.


PapoNL
2022-03-24T11:24:38Z
Originally Posted by: PapoNL 

Originally Posted by: Michael Fjellström 

Originally Posted by: PapoNL 

Going to test it with Time Trigger combined with 2 tasks

Task 1 email - get messages
Check inbox if contains unread mail that contains from adress %@email.com% and %subject% then save attachment to location X and leave message on server mark as read.

Task 2 email - move messages
Check inbox if contains read mail that contains from adress %@email.com% and %subject% then move mail to inbox\folder X


Tips are always welcome!




They get deactivated when they lose connection to the emailserver, you could increase these values/keep "Keep connection" checked

image.png



Got an example today with the keep connection option.
Its a different one im talking about then the one above.
Sometimes the event trigger (Mail) doesnt work correctly i looks like it does nothing.
I unchecked the box keep connection and then saved the JOB and after that de mails got moved as it should.




Like for today none of the event mail trigger are working.
Sometimes it works again if we select and update a job with a mail trigger by only open and close it via the OK button.
and then the last workaround what we normal do is restart the SERVER after that all event email trigger are working again.
Michael Fjellström
2022-03-24T14:02:59Z
Originally Posted by: PapoNL 

Originally Posted by: PapoNL 

Originally Posted by: Michael Fjellström 

Originally Posted by: PapoNL 

Going to test it with Time Trigger combined with 2 tasks

Task 1 email - get messages
Check inbox if contains unread mail that contains from adress %@email.com% and %subject% then save attachment to location X and leave message on server mark as read.

Task 2 email - move messages
Check inbox if contains read mail that contains from adress %@email.com% and %subject% then move mail to inbox\folder X


Tips are always welcome!




They get deactivated when they lose connection to the emailserver, you could increase these values/keep "Keep connection" checked

image.png



Got an example today with the keep connection option.
Its a different one im talking about then the one above.
Sometimes the event trigger (Mail) doesnt work correctly i looks like it does nothing.
I unchecked the box keep connection and then saved the JOB and after that de mails got moved as it should.




Like for today none of the event mail trigger are working.
Sometimes it works again if we select and update a job with a mail trigger by only open and close it via the OK button.
and then the last workaround what we normal do is restart the SERVER after that all event email trigger are working again.



How many email triggers do you use and how often are they expected to trigger approximately?
PapoNL
2022-03-24T14:21:16Z
Originally Posted by: Michael Fjellström 

Originally Posted by: PapoNL 

Originally Posted by: PapoNL 

Originally Posted by: Michael Fjellström 

Originally Posted by: PapoNL 

Going to test it with Time Trigger combined with 2 tasks

Task 1 email - get messages
Check inbox if contains unread mail that contains from adress %@email.com% and %subject% then save attachment to location X and leave message on server mark as read.

Task 2 email - move messages
Check inbox if contains read mail that contains from adress %@email.com% and %subject% then move mail to inbox\folder X


Tips are always welcome!




They get deactivated when they lose connection to the emailserver, you could increase these values/keep "Keep connection" checked

image.png



Got an example today with the keep connection option.
Its a different one im talking about then the one above.
Sometimes the event trigger (Mail) doesnt work correctly i looks like it does nothing.
I unchecked the box keep connection and then saved the JOB and after that de mails got moved as it should.




Like for today none of the event mail trigger are working.
Sometimes it works again if we select and update a job with a mail trigger by only open and close it via the OK button.
and then the last workaround what we normal do is restart the SERVER after that all event email trigger are working again.



How many email triggers do you use and how often are they expected to trigger approximately?



Around 544 (not all are used)
how often? is there a way to see a summary of that?
Because it can be 50 till 500 triggers a day if im not mistaking

Naamloos.png
Michael Fjellström
2022-03-25T13:26:25Z
Originally Posted by: PapoNL 

Originally Posted by: Michael Fjellström 

Originally Posted by: PapoNL 

Originally Posted by: PapoNL 

Originally Posted by: Michael Fjellström 

Originally Posted by: PapoNL 

Going to test it with Time Trigger combined with 2 tasks

Task 1 email - get messages
Check inbox if contains unread mail that contains from adress %@email.com% and %subject% then save attachment to location X and leave message on server mark as read.

Task 2 email - move messages
Check inbox if contains read mail that contains from adress %@email.com% and %subject% then move mail to inbox\folder X


Tips are always welcome!




They get deactivated when they lose connection to the emailserver, you could increase these values/keep "Keep connection" checked

image.png



Got an example today with the keep connection option.
Its a different one im talking about then the one above.
Sometimes the event trigger (Mail) doesnt work correctly i looks like it does nothing.
I unchecked the box keep connection and then saved the JOB and after that de mails got moved as it should.




Like for today none of the event mail trigger are working.
Sometimes it works again if we select and update a job with a mail trigger by only open and close it via the OK button.
and then the last workaround what we normal do is restart the SERVER after that all event email trigger are working again.



How many email triggers do you use and how often are they expected to trigger approximately?



Around 544 (not all are used)
how often? is there a way to see a summary of that?
Because it can be 50 till 500 triggers a day if im not mistaking

Naamloos.png



You have 544 Email *triggers* ? So every single job is an email trigger?
PapoNL
2022-03-29T14:53:39Z
we have 878 job and 544 have email triggers yes
PapoNL
2022-03-30T14:37:35Z
Originally Posted by: Michael Fjellström 

Originally Posted by: PapoNL 

Going to test it with Time Trigger combined with 2 tasks

Task 1 email - get messages
Check inbox if contains unread mail that contains from adress %@email.com% and %subject% then save attachment to location X and leave message on server mark as read.

Task 2 email - move messages
Check inbox if contains read mail that contains from adress %@email.com% and %subject% then move mail to inbox\folder X


Tips are always welcome!




They get deactivated when they lose connection to the emailserver, you could increase these values/keep "Keep connection" checked

image.png



with the Job above i get an internal server error 500. (like connection lost)
Even an event trigger mail with option " keep connection" checked has the same issue when you try to reselect the folder.

Is there something in Visual Cron to check this or reconnection Job or an other option?
Michael Fjellström
2022-04-07T12:39:14Z
Originally Posted by: PapoNL 

Originally Posted by: Michael Fjellström 

Originally Posted by: PapoNL 

Going to test it with Time Trigger combined with 2 tasks

Task 1 email - get messages
Check inbox if contains unread mail that contains from adress %@email.com% and %subject% then save attachment to location X and leave message on server mark as read.

Task 2 email - move messages
Check inbox if contains read mail that contains from adress %@email.com% and %subject% then move mail to inbox\folder X


Tips are always welcome!




They get deactivated when they lose connection to the emailserver, you could increase these values/keep "Keep connection" checked

image.png



with the Job above i get an internal server error 500. (like connection lost)
Even an event trigger mail with option " keep connection" checked has the same issue when you try to reselect the folder.

Is there something in Visual Cron to check this or reconnection Job or an other option?



Having that many email triggers/connections open to an email is not viable long term and won't work. Why do you have/need so many email triggers? If you explain in detail it might be easier to come up with a better solution
PapoNL
2022-04-26T07:57:13Z
in the meantime i learned a little more of VC.
Also using the get-message now it works much better.

Fused some Jobs together and system is also much more stable now.
Only the move-message gets an error sometimes but support is researching it.

Via this new flow it solves it self as well but would be nice when the error is solved.
example for the forum

Setting:
Time Trigger
Get-message - Unread emails
Move-message - Read emails

When the second time the trigger goes off he will move the read emails without error.


PapoNL
2022-06-14T09:20:33Z
I looks like since we changed the connections requests to the exchange server the problem is not anymore at the order.

imo; the function mail trigger doesn't work as nice as the get-mail task.

We don't get a lot of the usual error's anymore.

Michael Fjellström
2022-06-22T15:02:17Z
Originally Posted by: PapoNL 

I looks like since we changed the connections requests to the exchange server the problem is not anymore at the order.

imo; the function mail trigger doesn't work as nice as the get-mail task.

We don't get a lot of the usual error's anymore.



So with the exchange EWS connection the mail trigger still does not work for you?
PapoNL
2022-06-27T10:58:06Z
Its works, but not as stable as the GET-Message function.

That function works much better and imo when you have more then 20+ connections to one mailbox.
Scroll to Top