Firewall Issue with Remote Execute Task - VisualCron - Forum

Community forum

lhccs
  •  lhccs
  • No customer Topic Starter
2013-02-21T22:37:18Z
I'm running Visual Cron 6.1.4 from a server and am trying to execute a simple .bat file on a Windows XP machine. I received this error when executing the Remote Execute task:
Quote:

Exception in Task: The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)



I disabled the PC's Windows Firewall and the Remote Execute task ran fine. I re-enabled the firewall and tried adding an exception for port 16444 (both TCP and UDP) to the PC but I received the error again.

I know this is a firewall issue, but I don't know what exception I need to add to the PC to make it work. What am I missing?
Support
2013-02-22T08:11:54Z
16444 is not one of them - it is VisualCron specific.

WMI doesn't use a fixed port by default. Did you try opening up the port on the remote server like this: http://msdn.microsoft.com/en-us/library/aa822854 (VS.85).aspx? And here: http://msdn.microsoft.com/en-us/library/aa389290 (VS.85).aspx?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
lhccs
  •  lhccs
  • No customer Topic Starter
2013-02-22T18:53:55Z
That got me looking in the right direction, thanks.

I came across this article specifically regarding Windows XP and WMI: http://www.poweradmin.com/help/enableWMI.aspx 

Item #2 states:

Quote:

2. Allow WMI through Windows firewall

All users (including non-administrators) are able to query/read WMI data on the local computer.

For reading WMI data on a remote server, a connection needs to be made from your management computer (where our monitoring software is installed) to the server that you're monitoring (the target server). If the target server is running Windows Firewall (aka Internet Connection Firewall) like what is shipped with Windows XP and Windows 2003, then you need to tell it to let remote WMI requests through2. This can only be done at the command prompt. Run the following on the target computer if it is running a Windows firewall:

netsh firewall set service RemoteAdmin enable



Running the above command on the remote machine seems to have resolved the issue.
Scroll to Top