Archive - Extract task Issue - VisualCron - Forum

Community forum

twagner
2014-09-08T21:08:45Z
I have a FTP Job that downloads zipped files (no password, no encryption) and then attempts to decrypt them using the Archive - Extract function.
On the "Archive Type" within the Archive - Extract task I have chosen "Zip". I have other Jobs that extract on this same server that have the exact same settings and work fine. It seems to think that I have chosen "7z" as the archive type which I have not.

The error when trying to decrypt is this:

Exception in Task: SevenZip.SevenZipArchiveException: Invalid archive: open/read error! Is it encrypted and a wrong password was provided?
If your archive is an exotic one, it is possible that SevenZipSharp has no signature for its format and thus decided it is TAR by mistake.
at SevenZip.SevenZipBase.ThrowException(CallbackBase handler, Exception[] e)
at SevenZip.SevenZipExtractor.OpenArchive(IInStream archiveStream, ArchiveOpenCallback openCallback)
at SevenZip.SevenZipExtractor.GetArchiveInfo(Boolean disposeStream)
at SevenZip.SevenZipExtractor.ExtractArchive(String directory)
at OBOKIIHBDBPMCFALPGECCIFHCDJPEDKODDGK.IJDAGFJMLJFNHKOCGKCOJOBFEPMLKABILLJK.CDJMFGBLNJDPDEJFDKHPAHBBBBMJAIAOLEGJ() in C:\sourcefiles\code\VisualCronService\Jobs\TaskProcesses\File\Archive\clsProcessTaskArchiveDecompress.vb:line 166


I have done the following to try to resolve this.

1. Cloned the Archive - Extract task from a working job
2. Recreated the Archive - Extract task from scratch
3. Recreated the Archive - Extract task on a different server and verified that it worked then copied to the server it fails on.
4. Restarted the Service
5. Restarted the Server
6. Verified that the compressed files are good and decryptable outside of VC
7. Upgraded from 7.15 to 7.20

It seems that VC continues to think 7z has been chosen and therefore fails.
Nothing has worked, any ideas?
Support
2014-09-11T08:27:25Z
Could you please send the file and screenshots of the Task to support@visualcron.com?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
twagner
2014-09-11T16:10:39Z
I have sent the screenshots.

Update:
I changed the FTP connection settings to Binary and this resolved the issue.
Scroll to Top