Just upgrade to 8.2 and now have some FTP tasks failing - PLEASE HELP - VisualCron - Forum

Community forum

JohnC
  •  JohnC
  • Free support Topic Starter
2016-05-09T17:54:05Z
We just upgraded VisualCron from version 7 to 8.1.0.

Immediately after the upgrade, we started having a problem with some of our jobs that make use of secure FTP to download files to the server. Although these jobs worked on Friday prior to upgrade, these same jobs now throw the following error.

Exception in Task: Failed to download file: Tri_ED:/Invoice/tri-ed_20160506.09301520.dat to F:\EDI_DATA\TRIED\IN\Tri_ED:\Invoice\tri-ed_20160506.09301520.dat, err: System.NotSupportedException: The given path's format is not supported.
at System.Security.Util.StringExpressionSet.CanonicalizePath(String path, Boolean needFullPath)
at System.Security.Util.StringExpressionSet.CreateListFromExpressions(String[] str, Boolean needFullPath)
at System.Security.Permissions.FileIOPermission.AddPathList(FileIOPermissionAccess access, AccessControlActions control, String[] pathListOrig, Boolean checkForDuplicates, Boolean needFullPath, Boolean copyPathList)
at System.Security.Permissions.FileIOPermission.AddPathList(FileIOPermissionAccess access, String[] pathListOrig, Boolean checkForDuplicates, Boolean needFullPath, Boolean copyPathList)
at System.IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost)
at VisualCronService.RemoteFileAPI.CIEPIMOCDDKPCGAGAEAJKJAPPBMFHHHAIHKN(CCEDIKOJOACMABGAIHHOHPJCDMJPDMLJKHNK , ConnectionClientClass , ConnectionHandlerClass , String , List`1 AAKGMOLAGMKIFCIPNNDJJKDPNLOEMAABEGOB, String , FTPDownloadCommandClass , Int32& , Boolean& , VariableReplacerClass , TaskProcessClass ) in C:\sourcefiles\code\VisualCronService\Connection\apiRemoteFile.vb:line 1053
Exception in Task: No file(s) downloaded

Could someone please provide some guidance on how to troubleshoot and resolve this error? As best I can determine, the connections are still valid and correct as VC will allow me to navigate to the folder and I can see a number of files there waiting to be downloaded.

Please help.
bbusse
2016-05-09T18:57:17Z
Can you post a screenshot of your destination configuration of the FTP copy step?

This doesn't look like a valid path to me, but that could just be VC messing something up in the new version. Which is why i'd want to see what you see:

(note the colon ( : ) after Tri_ED

F:\EDI_DATA\TRIED\IN\Tri_ED:\Invoice\tri-ed_20160506.09301520.dat

Brian
Support
2016-05-09T19:07:55Z
Hi,

we would like to know;

1. full path on FTP server
2. destination path
3. download settings (screenshot please)
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
icbuser
2016-05-12T16:18:26Z
This happened to us too: Check on download tasks make sure you "Save files to destination folder"

Everytime we upgrade Visualcron we have to scrub all download tasks and make sure the option is selected.
Scroll to Top