Please note that VisualCron support is not actively monitoring this community forum. Please use our contact page for contacting the VisualCron support directly.

Praxis Consulting
I'm running into a problem where I can no longer add SQL tasks that access a stored procedure. Here's what happens:

I add a SQL task to existing job.
Click SQL tab
Select my pre-existing DB connection (which is already being used in another task in this job; it's been running successfully for months)
Click Stored Procedure tab
Click the refresh button to load available stored procedures into the drop down
It then freezes for a couple minutes, and eventually comes up with an error popup: "Command not understood. Consider upgrading Server."

Some other ways I tried:
-- attempting to type the stored procedure name in results in long freezes between each letter
-- copy/pasting the stored procedure name in, and then clicking refresh, freezes and then pops up the error: "Unhandled error occured while trying to refresh, error:". Note the error is blank.
-- This has the same result in a completely new job as well.
-- Trying a different DB connection to a different DB results in the same errors.

Other info:
-- Already existing SQL tasks run normally.
-- I can access the DB via Connection Explorer normally.
-- Visual Cron version 8.2.3
-- I believe this is the first time I've tried to add a DB task since upgrading to version 8
-- Since upgrading to version 8 a couple months ago Visual Cron has not run as smooth as it did in 7. I have more long running jobs; often a job's log will come up blank or will error out; often when I try to do something, I'll have to wait while it freezes with "(Not Responding)" in the title bar; just ran an export settings -- ten minutes later, it's still sitting there on "requesting export".
-- running on Windows 2012
-- Visual Cron is the only app running on this server

Thanks for your help.
Forum information
1. what kind of DB is it? MSSQL?
2. Do you use MSSQL or OLEDB or ODBC?
3. if you turn on Extended debugging in server settings do you get any error in the log log_serverDATE.txt? Please paste it here.
Please like  VisualCron on facebook!
Praxis Consulting
It's a MSSQL DB, with MSSQL connection.

Note: I decided to try reinstalling Visual Cron 8.2.3 to see if having a completely clean install would help. Once I was running again, it worked... Once. after that, same error.

That was yesterday. Today I launch it to get the log output and... it works again. At least long enough for me to one of the tasks I've been needing to add. After that I tried adding another one, and we're back to the same error. I close the VC GUI, relaunch and try again, and now it works again (it got the sproc list instantly that time too). Several retries worked.

Then, after waiting a few minutes with the edit task panel sitting open, I tried refreshing sprocs again and it failed again. Same pattern, long pause, "Not Responding", and then finally the popup error "Command not understood. Consider upgrading Server." (with "Send failure" in popup header bar). Below is the error from the log, everything in between the last "Job completed" entry and the next "Job started" entry:

2/3/2017 5:35:09 PM Info JobAPI->Save->Saving Jobs (45) - in shut down: False
2/3/2017 5:35:23 PM Info Task Notification completed (Failure)->'Job Success' (358293)
2/3/2017 5:35:23 PM Err Task Notification failed with error:
2/3/2017 5:35:23 PM Debug RemoveTaskProcess-> Could not find TaskProcess (358293) Task: Job Success
2/3/2017 5:36:26 PM Debug Saving output files and clearing output memory.
2/3/2017 5:36:26 PM Debug Output stored in memory: 87
2/3/2017 5:36:26 PM Debug Calling CleanUp
2/3/2017 5:36:26 PM Debug Standard Output count: 45
2/3/2017 5:36:26 PM Debug Standard Output size: 0.00
2/3/2017 5:36:26 PM Debug Standard Error count: 42
2/3/2017 5:36:26 PM Debug Standard Error size: 0.00
2/3/2017 5:36:26 PM Debug Memory usage before cleanup: 83263488
2/3/2017 5:36:26 PM Debug Log was trimmed from: 1047 to 1000
2/3/2017 5:36:26 PM Debug RemoveConnection->Enter
2/3/2017 5:36:26 PM Debug RemoveConnection->ConnClass->Before disconnect (WCF)
2/3/2017 5:36:26 PM Debug RemoveConnection->ConnClass->After disconnect (WCF)
2/3/2017 5:36:26 PM Debug RemoveConnection->Connection removed from dictionary.
2/3/2017 5:36:26 PM Debug Before sending ClientConnection (Delete)
2/3/2017 5:36:26 PM Debug RemoveConnection->Connection: uuid:c4b47b35-fddc-4fe4-9099-b9b7b7498aff;id=5 was removed
2/3/2017 5:36:26 PM Debug clsCommClientThread->Disconnected->Connection removed: uuid:c4b47b35-fddc-4fe4-9099-b9b7b7498aff;id=5
2/3/2017 5:36:26 PM Debug ConnectionManager_ConnectionRemoved->Connection removed (Server Event): uuid:c4b47b35-fddc-4fe4-9099-b9b7b7498aff;id=5
2/3/2017 5:36:26 PM Err MessageSending (ToAll) error: System.ServiceModel.CommunicationObjectAbortedException: The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it has been Aborted.

Server stack trace:
at System.ServiceModel.Channels.CommunicationObject.ThrowIfDisposedOrNotOpen()
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at CommServer.Classes.WCF.WCFConnection.NotifyError(Exception exception)
at CommServer.Classes.WCF.WCFConnection.Send(Message message)
at VisualCronService.clsCommClientThread.NFGCOCNOLLFCIDPMBNANLIOIFJENIMMDOPCO(Byte[] , MessageClass , String , Boolean ) in C:\sourcefiles\code\VisualCronService\Connection\clsCommClientThread.vb:line 107

Are you using same version of Client and Server?
Can you reproduce this if you connect locally on the machine?
Please like  VisualCron on facebook!
Praxis Consulting
Yes, it's the same version of client and server. This was all done locally; I never connect remotely.
Please install this build: 

Make sure you have Extended debugging on in Server settings. After trying to refresh please send the file log_serverDATE.txt to
Please like  VisualCron on facebook!
Praxis Consulting
I uninstalled and installed that build -- so far, no errors.
Originally Posted by: Praxis Consulting 

I uninstalled and installed that build -- so far, no errors.

I think we capture any errors in log. Is it listed normally now? Can you pleases end log_serverDATE.txt to after refreshing?
Please like  VisualCron on facebook!
Scroll to Top