how to exclude specific files in a copy files task - VisualCron - Forum

Community forum

martymcfly57
2017-11-13T15:18:00Z
Hello everybody,

I'm newbie with Visual Cron and I have a problem to create copy files task.

I'm trying to copy all log files in c:\data\logs\ folder so no problem to do this with "include file mask" filled with "*.log", but I have some conditions for the task :

Condition 1 : there are subfolders with log files and also log files stored directy on c:\data\logs\
==> I have ticked "include sub folders" and it works fine

Condition 2 : I would like to copy only log files which are stored in sub folders (or to exclude log files stored directly on c:\data\logs\)

Here I have tested several things without success :
- I ticked "use file exclusion" and filled "excluded file mask" like this test1.log;toto2.log;report.log etc
==> copy process works but excluded files are copied too...

- I tried also to modify the source folder in order to specify c:\data\logs\* and to untick "include sub folders" and untick "use file exclusion"
==> copy process works for the first subfolder : all logs have been copied, but I have 10 subfolders and after the first one I get an error message 77777 : ErreurException in Task: path format is not accepted

I think I have missed something on my test so If somebody can help me I thank him or her in advance 🙂
Gary_W
2017-11-13T19:21:53Z
Sorry I can't test right now but I would try this in the exclusion file mask "c:\data\logs\*.log" while leaving the include subfolders checked.
Scroll to Top