Web Macro copy link step - VisualCron - Forum

Community forum

bweston
2020-03-31T15:41:53Z
I have a web macro that has been around since major version 7, I think.

Since upgrading from 8.5.5 to 9.1.5 (at least, I think that is when it started), when the macro gets to the step where it is supposed to copy the link to a job variable, it gets this error.

Exception in Task: Current thread must be set to single thread apartment (STA) mode before OLE calls can be made. Ensure that your Main function has STAThreadAttribute marked on it.

From the looks of things this does not actually prevent the variable from being set, which would have saved me quite a bit of time if I'd noticed it sooner, but it does cause the task to fail.
Support
2020-04-02T09:42:00Z
Originally Posted by: bweston 

I have a web macro that has been around since major version 7, I think.

Since upgrading from 8.5.5 to 9.1.5 (at least, I think that is when it started), when the macro gets to the step where it is supposed to copy the link to a job variable, it gets this error.

Exception in Task: Current thread must be set to single thread apartment (STA) mode before OLE calls can be made. Ensure that your Main function has STAThreadAttribute marked on it.

From the looks of things this does not actually prevent the variable from being set, which would have saved me quite a bit of time if I'd noticed it sooner, but it does cause the task to fail.



Could you send an export of your web macro task/job to us? On support@visualcron.com

Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
bweston
2020-04-03T12:59:46Z
I'm not sure when I might have time to construct a separate example in order to provide something that would actually demonstrate it; I can't share the credentials it operates behind.
Support
2020-04-06T13:47:07Z
Originally Posted by: bweston 

I'm not sure when I might have time to construct a separate example in order to provide something that would actually demonstrate it; I can't share the credentials it operates behind.



Ok I understand,

Are you able to record a video snippet of the whole process/the error?
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
Scroll to Top