Community forum

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Offline abhijeet_kumar.patil  
#1 Posted : Thursday, November 1, 2018 2:04:26 PM(UTC)
abhijeet_kumar.patil

Rank: Paid support

Joined: 4/4/2018(UTC)
Posts: 12
India
Location: Maharashtra

Visual Cron Service is set to automatic start but when server reboot happens the Sagent service do not start automatically.
Offline Support  
#2 Posted : Thursday, November 1, 2018 2:50:07 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,167

Thanks: 866 times
Was thanked: 443 time(s) in 421 post(s)
What is the Sagent service?
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline abhijeet_kumar.patil  
#3 Posted : Thursday, November 1, 2018 3:57:48 PM(UTC)
abhijeet_kumar.patil

Rank: Paid support

Joined: 4/4/2018(UTC)
Posts: 12
India
Location: Maharashtra

Sagent Service is the service on which the sagent tool runs. It is available in Administrative Tool --> Services.

Kindly find attached screenshot.Service_Screen_Shot.PNG
Offline Support  
#4 Posted : Friday, November 2, 2018 4:44:49 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,167

Thanks: 866 times
Was thanked: 443 time(s) in 421 post(s)
Originally Posted by: abhijeet_kumar.patil Go to Quoted Post
Sagent Service is the service on which the sagent tool runs. It is available in Administrative Tool --> Services.

Kindly find attached screenshot.Service_Screen_Shot.PNG


So, what has that service to do with VisualCron?
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline abhijeet_kumar.patil  
#5 Posted : Monday, November 5, 2018 6:58:29 AM(UTC)
abhijeet_kumar.patil

Rank: Paid support

Joined: 4/4/2018(UTC)
Posts: 12
India
Location: Maharashtra

If we stop VisualCron service (highlighted in trailing post) then visual cron stops working. My problem is, sometimes due to maintenance activities the server is restarted over the weekend. At this point even though the VisualCron service is set to automatic restart; the service remains in 'STOP' status. This stops the visual cron. Let us know if can schedule call on this.
Offline abhijeet_kumar.patil  
#6 Posted : Monday, November 19, 2018 11:41:10 AM(UTC)
abhijeet_kumar.patil

Rank: Paid support

Joined: 4/4/2018(UTC)
Posts: 12
India
Location: Maharashtra

Hi Team,
Could you please provide an update on this? This is urgent.

Regards,
Abhijeet
Offline Support  
#7 Posted : Monday, November 19, 2018 8:28:48 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,167

Thanks: 866 times
Was thanked: 443 time(s) in 421 post(s)
Automatic Restart means the service (in this case VisualCron) will start if it fails. It sounds like you expecting something else but this is the behaviour of Windows.
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline abhijeet_kumar.patil  
#8 Posted : Tuesday, November 20, 2018 7:26:11 AM(UTC)
abhijeet_kumar.patil

Rank: Paid support

Joined: 4/4/2018(UTC)
Posts: 12
India
Location: Maharashtra

Hi Henrik,
If the server is restarted again then I see that the other services are in running status. But this is not the case with VisualCron service. When restart happens then the service moves to STOP mode. We need to manually start the service. This is not the normal behavior of the windows right.

If you restart your personal PC and try to open MS Excel then it will not throw error to start the service related to MS Excel. But this is happening with VC. When I try to open VC it ask to start the service associated to it.
Offline Support  
#9 Posted : Tuesday, November 20, 2018 12:20:13 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,167

Thanks: 866 times
Was thanked: 443 time(s) in 421 post(s)
Originally Posted by: abhijeet_kumar.patil Go to Quoted Post
Hi Henrik,
If the server is restarted again then I see that the other services are in running status. But this is not the case with VisualCron service. When restart happens then the service moves to STOP mode. We need to manually start the service. This is not the normal behavior of the windows right.

If you restart your personal PC and try to open MS Excel then it will not throw error to start the service related to MS Excel. But this is happening with VC. When I try to open VC it ask to start the service associated to it.


I am not following you at all. When you say restart service I am not sure if you talk about your service or VC service.

Your example does not make sense as there is no "service" associated with MS Excel at all. At least not to open a normal document.
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline abhijeet_kumar.patil  
#10 Posted : Tuesday, November 20, 2018 12:59:13 PM(UTC)
abhijeet_kumar.patil

Rank: Paid support

Joined: 4/4/2018(UTC)
Posts: 12
India
Location: Maharashtra

Hi Henrik,
If you don't follow me then let me explain at very very basic level.

1) If you start your computer and go to 'Run' and type services.msc you will find list of local services as per attachment.Service.PNG
2) There is one service related to VisualCron. The name of the service is 'VisualCron'. [Hopefully you might find this the same attachment]
3) As you can see in the attachment then there are other services too along with 'VisualCron'.
4) When the server is restarted then rest of the services remain in 'Started' status but VisualCron service remain in 'Stop' status even though the start type is automatic [please see the same screenshot again for startup type. Column number 4].
5) We want to know why the VisualCron service do not remain in 'Started' status once the server is restarted. We need to manually start this service one time until next server reboot happens.

Hope you understand this. If not kindly call my cell +917757055995 as this is critical and we are chasing for this from long time without any progress.
Offline thomas  
#11 Posted : Tuesday, November 20, 2018 1:24:37 PM(UTC)
thomas

Rank: Paid support

Joined: 12/10/2013(UTC)
Posts: 442
Norway

Thanks: 21 times
Was thanked: 170 time(s) in 129 post(s)
right, so the Sagent service has nothing to do with this.. You started by posting a screenshot where the sagent service was highlighted, so I was at least as confused as Henrik:)

I'm certainly no expert, but I would try this
1) Check the event log and see if you if you can find any error messages when rebooting server
2) Try changing from Automatic to Automatic Delayed and see if helps
3) You can also add a retry on the recovery tab and see if it helps.
Offline abhijeet_kumar.patil  
#12 Posted : Tuesday, November 20, 2018 1:49:03 PM(UTC)
abhijeet_kumar.patil

Rank: Paid support

Joined: 4/4/2018(UTC)
Posts: 12
India
Location: Maharashtra

Hi Team,
We have reached out to respective team but nothing was traced in the logs. They updated that this is happing for single application only so reach out to the vendor of VisualCron application.

Also rest of the two options are tried but did not got any positive response.
Offline thomas  
#13 Posted : Tuesday, November 20, 2018 2:00:24 PM(UTC)
thomas

Rank: Paid support

Joined: 12/10/2013(UTC)
Posts: 442
Norway

Thanks: 21 times
Was thanked: 170 time(s) in 129 post(s)
Have you created some kind of dependency between the Sagent service and VisualCron? I'm asking since you started the thread talking about Sagent and not vc. That part is very confusing. It would be very helpful if you could explain if Sagent has anything to do with this.
Offline abhijeet_kumar.patil  
#14 Posted : Tuesday, November 20, 2018 2:14:31 PM(UTC)
abhijeet_kumar.patil

Rank: Paid support

Joined: 4/4/2018(UTC)
Posts: 12
India
Location: Maharashtra

Service level there is no dependency. Capture.PNG
Offline thomas  
#15 Posted : Tuesday, November 20, 2018 2:27:08 PM(UTC)
thomas

Rank: Paid support

Joined: 12/10/2013(UTC)
Posts: 442
Norway

Thanks: 21 times
Was thanked: 170 time(s) in 129 post(s)
ok. We can finally ignore Sagent. When you starting the thread with Sagent services, it wasted a lot of time to be honest

In this link there are 5 reasons why services may not start after reboot. You seem to have tried four of them. I would look at the group policy item (nr 4).
https://www.coretechnolo...s-service-start-at-boot/
Users browsing this topic
Guest
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Scroll to Top