Issue with VB6 Application Running Crystal Report only when Task run from... - VisualCron - Forum

Community forum

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Offline gjenkins  
#1 Posted : Monday, February 10, 2020 6:19:26 PM(UTC)
gjenkins

Rank: No customer

Joined: 2/1/2020(UTC)
Posts: 4
Canada
Location: Newfoundland and Labrador, St. John's

We have a very niche issue where we want to run a VB6 executable that generates several crystal reports. It works if we run the executable manually, however if we run the executable as a task from VisualCron we get the error "Automation error The object invoked has disconnected from its clients. -2147417848". We were able to trace the point of failure to the line of code "Form1.CrystalReport1.Action = 1", which just executes the actual report once all the parameters have been set. Any suggestions how to fix?
Offline Support  
#2 Posted : Tuesday, February 11, 2020 3:16:06 PM(UTC)
Support

Rank: Official support

Joined: 12/1/2015(UTC)
Posts: 299

Thanks: 44 times
Was thanked: 15 time(s) in 14 post(s)
Originally Posted by: gjenkins Go to Quoted Post
We have a very niche issue where we want to run a VB6 executable that generates several crystal reports. It works if we run the executable manually, however if we run the executable as a task from VisualCron we get the error "Automation error The object invoked has disconnected from its clients. -2147417848". We were able to trace the point of failure to the line of code "Form1.CrystalReport1.Action = 1", which just executes the actual report once all the parameters have been set. Any suggestions how to fix?


Hi, it sounds like some permission issue. Could you try running it in Foreground instead of background? Also, screenshots of your current task settings would be helpful, you could mail those to support@visualcron.com
Michael
Support
http://www.visualcron.com

Please like VisualCron on facebook!
Offline gjenkins  
#3 Posted : Wednesday, February 12, 2020 8:25:01 PM(UTC)
gjenkins

Rank: No customer

Joined: 2/1/2020(UTC)
Posts: 4
Canada
Location: Newfoundland and Labrador, St. John's

We actually got around this by updating to a slightly newer version of VisualCron. Thank you for the reply!
Offline Support  
#4 Posted : Thursday, February 13, 2020 11:34:17 AM(UTC)
Support

Rank: Official support

Joined: 12/1/2015(UTC)
Posts: 299

Thanks: 44 times
Was thanked: 15 time(s) in 14 post(s)
Originally Posted by: gjenkins Go to Quoted Post
We actually got around this by updating to a slightly newer version of VisualCron. Thank you for the reply!


That's good! Thanks for updating.
Michael
Support
http://www.visualcron.com

Please like VisualCron on facebook!
Users browsing this topic
Guest
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Scroll to Top