5.1.1 - bug fixes and some small features - VisualCron - Forum

Community forum

Support
2009-04-19T13:30:11Z
The following things are new in this version:

[FEATURE] Server: Kill and Timeout now kills whole process tree (child processes)
[FEATURE] Server: Added support for DATEFORMAT Variable in date comparison
[FEATURE] Server: Added PermissionDenied error handling for File delete Task
[FEATURE] Server: Added IOException error handling for File delete Task
[FEATURE] Server: Added PermissionDenied error handling for Copy files Task
[FEATURE] Server: Added UnahandledException error handling for Copy files Task
[FEATURE] Server: Added IOException error handling for Copy files Task
[FEATURE] Server: Added String.GUID Variable
[BUGFIX] Server: Fixed a problem with anonymous FTP servers
[BUGFIX] Client/Server/API: Fixed a problem with editing and changing own password in Permissions
[BUGFIX] Client: Fixed a GUI error with SSL switching in Connections
[BUGFIX] Client/Server: Reverted back to original handling of public key authentication in SFTP
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
shassan
2009-04-19T17:54:43Z
Great,

thanks a lot.
Tested and it works 😎


We will go back to you soon in order to subscribe.

Samatar
viper8
2009-05-28T20:51:14Z
[BUGFIX] Client/Server: Reverted back to original handling of public key authentication in SFTP

Hello,

Is there any chance this can be reverted for the SSH Connection type as well? I'm running 5.1.2 and can use private keys with SFTP connections just fine, but am unable to select a private key when defining an SSH connection. It is basically grayed out.

Thanks!
Support
2009-05-28T23:02:05Z
Thanks for the reminder. It is fixed for next version.

viper8 wrote:

[BUGFIX] Client/Server: Reverted back to original handling of public key authentication in SFTP

Hello,

Is there any chance this can be reverted for the SSH Connection type as well? I'm running 5.1.2 and can use private keys with SFTP connections just fine, but am unable to select a private key when defining an SSH connection. It is basically grayed out.

Thanks!



Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
viper8
2009-05-29T17:15:18Z
Great!! That will be a very helpful function for us. Thank you Henrik!
viper8
2009-07-02T17:17:09Z
Hello,

I'm looking to test this functionality..could you tell me which version the fix is in?

Thanks

Support wrote:

Thanks for the reminder. It is fixed for next version.

viper8 wrote:

[BUGFIX] Client/Server: Reverted back to original handling of public key authentication in SFTP

Hello,

Is there any chance this can be reverted for the SSH Connection type as well? I'm running 5.1.2 and can use private keys with SFTP connections just fine, but am unable to select a private key when defining an SSH connection. It is basically grayed out.

Thanks!



Support
2009-07-02T18:22:05Z
I believe it was fixed in 5.1.2. but I recommend installing 5.2.0 right now.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
viper8
2009-07-07T20:04:02Z
Okay great, version 5.2.0 has the functionality and it is working properly. Thank you!

Support wrote:

I believe it was fixed in 5.1.2. but I recommend installing 5.2.0 right now.


viper8
2009-07-07T21:01:46Z
I take that back...after doing some testing I found that it is not working properly. When defining an SSH connection, in the Security tab I set the Authentication Type to Public Key and then choose a Private Key file. I choose the file and then click OK. Go back to that particular connection and the Private Key file that I just set it to use is no longer defined. It's losing that setting. What can I do to help fix this?

Thanks
Support
2009-07-08T12:39:00Z
Hmm..we will take a look again and get back to you. Thank you for the notification.

viper8 wrote:

I take that back...after doing some testing I found that it is not working properly. When defining an SSH connection, in the Security tab I set the Authentication Type to Public Key and then choose a Private Key file. I choose the file and then click OK. Go back to that particular connection and the Private Key file that I just set it to use is no longer defined. It's losing that setting. What can I do to help fix this?

Thanks



Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2009-07-09T22:46:23Z
This is now fixed in 5.2.1.

Support wrote:

Hmm..we will take a look again and get back to you. Thank you for the notification.

viper8 wrote:

I take that back...after doing some testing I found that it is not working properly. When defining an SSH connection, in the Security tab I set the Authentication Type to Public Key and then choose a Private Key file. I choose the file and then click OK. Go back to that particular connection and the Private Key file that I just set it to use is no longer defined. It's losing that setting. What can I do to help fix this?

Thanks




Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top