Failed to Connect to Credential Provider - 7.6.5 version - VisualCron - Forum

Community forum

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Offline LaurentCL  
#1 Posted : Tuesday, August 9, 2016 11:06:25 AM(UTC)
LaurentCL

Rank: Free support

Joined: 8/9/2016(UTC)
Posts: 2
France
Location: Paris

Hi,

We are currenlty migrating windows scheduler jobs (WS2003) to Visual Cron (WS2012 R2).
System is X64.

We enabled the "Do not Require CTRL + ALT + DEL" policy as we need to execute foreground applications.
However, task is always failing with message : "Desktop Unlock/Logon failed in task: Exécuter, reason: Failed to connect to Credential Provider"

I activated extended debbuging, and I can see some warnings :

Quote:

09/08/16 11:01:30 AM Info Job started: notepad
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : TriggerResult
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : TriggerResult
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : TriggerResult
09/08/16 11:01:30 AM Info User 'VisualCron Default Admin' - Ran Job: notepad
09/08/16 11:01:30 AM Debug 2016-08-09 09:01:30.793: MessageSend To (Private) uuid:627a149d-87ce-4cfb-8b0b-9c4e8def90f9;id=12: JobRunResult
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : VCJobProcess
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : VCJobProcess
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : VCJobProcess
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : JobStats
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : JobStats
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : JobStats
09/08/16 11:01:30 AM Debug SendJobStats->Ended (09/08/16 11:01:30 AM)
09/08/16 11:01:30 AM Info Skipping Condition check because the Job was run manually.
09/08/16 11:01:30 AM Debug Next action: ActionContinue
09/08/16 11:01:30 AM Debug Calling GetNextTaskProcess()
09/08/16 11:01:30 AM Debug Next Task is: Exécuter
09/08/16 11:01:30 AM Debug Next action: ActionContinue
09/08/16 11:01:30 AM Debug Calling StartTaskProcess() with Task: Exécuter (0)
09/08/16 11:01:30 AM Info Task started: Exécuter (2311)
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : VCTaskProcess
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : VCTaskProcess
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : VCTaskProcess
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : TaskStats
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : TaskStats
09/08/16 11:01:30 AM Debug MessageSend (ToAll) To (Empty) : TaskStats
09/08/16 11:01:30 AM Debug Interactive logon: LoginIfNeeded() invoked for user: userweuse, password is not empty
09/08/16 11:01:30 AM Debug Interactive logon: Could no find screensaver configuration found for user: .DEFAULT
09/08/16 11:01:30 AM Debug Interactive logon: Could no find screensaver configuration found for user: S-1-5-19
09/08/16 11:01:30 AM Debug Interactive logon: Could no find screensaver configuration found for user: S-1-5-20
09/08/16 11:01:30 AM Debug Interactive logon: Could no find screensaver configuration found for user: S-1-5-21-2052699199-3915784498-1582209984-101599
09/08/16 11:01:30 AM Debug Interactive logon: Could no find screensaver configuration found for user: S-1-5-18
09/08/16 11:01:30 AM Debug Interactive logon: Screensaver is not running.
09/08/16 11:01:30 AM Debug Interactive logon: Dumping sessions.
09/08/16 11:01:30 AM Debug Interactive logon: Session id: 0, username: , state: WTSDisconnected
09/08/16 11:01:30 AM Debug Interactive logon: Session id: 1, username: , state: WTSConnected
09/08/16 11:01:30 AM Debug Interactive logon: Session id: 2, username: userweuse, state: WTSActive
09/08/16 11:01:30 AM Debug Interactive logon: Session id: 65536, username: , state: WTSListen
09/08/16 11:01:30 AM Debug Interactive logon: Sessions dump ended.
09/08/16 11:01:30 AM Debug Interactive logon: Active Console Session id = 1
09/08/16 11:01:30 AM Debug Interactive logon: Active User Name =
09/08/16 11:01:30 AM Debug Interactive logon: EstablishConnection->Create file - retry: 0
09/08/16 11:01:30 AM Debug Interactive logon: EstablishConnection->Invalid value (-1)
09/08/16 11:01:30 AM Debug Interactive logon: EstablishConnection->Pipe busy - waiting for 10 seconds
09/08/16 11:01:30 AM Debug Interactive logon: EstablishConnection->Wait named pipe failed - try EstablishConnection again
09/08/16 11:01:32 AM Debug 2016-08-09 09:01:32.371: MessageRecived From (in) uuid:627a149d-87ce-4cfb-8b0b-9c4e8def90f9;id=12: Ping
09/08/16 11:01:32 AM Debug 2016-08-09 09:01:32.371: MessageSend To (Private) uuid:627a149d-87ce-4cfb-8b0b-9c4e8def90f9;id=12: Ping
09/08/16 11:01:32 AM Debug 2016-08-09 09:01:32.403: MessageRecived From (in) uuid:627a149d-87ce-4cfb-8b0b-9c4e8def90f9;id=13: Ping
09/08/16 11:01:32 AM Debug 2016-08-09 09:01:32.403: MessageSend To (Private) uuid:627a149d-87ce-4cfb-8b0b-9c4e8def90f9;id=13: Ping
09/08/16 11:01:32 AM Debug Interactive logon: EstablishConnection->Create file - retry: 1
09/08/16 11:01:32 AM Debug Interactive logon: EstablishConnection->Invalid value (-1)
09/08/16 11:01:32 AM Debug Interactive logon: EstablishConnection->Pipe busy - waiting for 10 seconds
09/08/16 11:01:32 AM Debug Interactive logon: EstablishConnection->Wait named pipe failed - try EstablishConnection again
09/08/16 11:01:34 AM Debug Interactive logon: EstablishConnection->Create file - retry: 2
09/08/16 11:01:34 AM Debug Interactive logon: EstablishConnection->Invalid value (-1)
09/08/16 11:01:34 AM Debug Interactive logon: EstablishConnection->Pipe busy - waiting for 10 seconds
09/08/16 11:01:34 AM Debug Interactive logon: EstablishConnection->Wait named pipe failed - try EstablishConnection again
09/08/16 11:01:36 AM Debug Interactive logon: EstablishConnection->Create file - retry: 3
09/08/16 11:01:36 AM Debug Interactive logon: EstablishConnection->Invalid value (-1)
09/08/16 11:01:36 AM Debug Interactive logon: EstablishConnection->Pipe busy - waiting for 10 seconds
09/08/16 11:01:36 AM Debug Interactive logon: EstablishConnection->Wait named pipe failed - try EstablishConnection again
09/08/16 11:01:38 AM Debug 2016-08-09 09:01:38.856: MessageRecived From (in) uuid:627a149d-87ce-4cfb-8b0b-9c4e8def90f9;id=11: Ping
09/08/16 11:01:38 AM Debug 2016-08-09 09:01:38.856: MessageSend To (Private) uuid:627a149d-87ce-4cfb-8b0b-9c4e8def90f9;id=11: Ping
09/08/16 11:01:38 AM Debug Interactive logon: EstablishConnection->Number of retries exceeded - exiting
09/08/16 11:01:38 AM Debug Interactive logon: Workstation is locked = False
09/08/16 11:01:38 AM Debug Interactive logon: Multiple sessions allowed = True
09/08/16 11:01:38 AM Debug Interactive logon: There is no interactive user. Logging in target user.
09/08/16 11:01:38 AM Debug Interactive logon: EstablishConnection->Create file - retry: 0
09/08/16 11:01:38 AM Debug Interactive logon: EstablishConnection->Invalid value (-1)
09/08/16 11:01:38 AM Debug Interactive logon: EstablishConnection->Pipe busy - waiting for 10 seconds
09/08/16 11:01:38 AM Debug Interactive logon: EstablishConnection->Wait named pipe failed - try EstablishConnection again
09/08/16 11:01:40 AM Debug Interactive logon: EstablishConnection->Create file - retry: 1
09/08/16 11:01:40 AM Debug Interactive logon: EstablishConnection->Invalid value (-1)
09/08/16 11:01:40 AM Debug Interactive logon: EstablishConnection->Pipe busy - waiting for 10 seconds
09/08/16 11:01:40 AM Debug Interactive logon: EstablishConnection->Wait named pipe failed - try EstablishConnection again
09/08/16 11:01:42 AM Debug Interactive logon: EstablishConnection->Create file - retry: 2
09/08/16 11:01:42 AM Debug Interactive logon: EstablishConnection->Invalid value (-1)
09/08/16 11:01:42 AM Debug Interactive logon: EstablishConnection->Pipe busy - waiting for 10 seconds
09/08/16 11:01:42 AM Debug Interactive logon: EstablishConnection->Wait named pipe failed - try EstablishConnection again
09/08/16 11:01:44 AM Debug Interactive logon: EstablishConnection->Create file - retry: 3
09/08/16 11:01:44 AM Debug Interactive logon: EstablishConnection->Invalid value (-1)
09/08/16 11:01:44 AM Debug Interactive logon: EstablishConnection->Pipe busy - waiting for 10 seconds
09/08/16 11:01:44 AM Debug Interactive logon: EstablishConnection->Wait named pipe failed - try EstablishConnection again
09/08/16 11:01:46 AM Debug Interactive logon: EstablishConnection->Number of retries exceeded - exiting
09/08/16 11:01:46 AM Debug Interactive logon: Exception in LoginIfNeeded, exception: InteractiveLogonComponent.ILCException: Failed to connect to Credential Provider
at DMKKGLIMCJDNDCNFFAHFGECPGMEIKAIAPILJ.DKMDMPDOBJBEEEAHDMIHGAMIDLNCHCEEDOAA.NONIDPAJGFBKNBMPKPMDBPBFEKPHMMKEHIJA(String , String , String )
at InteractiveLogonComponent.CInteractiveLogonComponent.GCNJLKPCAALGENLLIIGBLMLJAOKAGIDLBDOB(String , String , String )
at InteractiveLogonComponent.CInteractiveLogonComponent.LoginIfNeeded(String user, String pass, String domain)
09/08/16 11:01:46 AM Err Desktop Unlock/Logon failed in task: Exécuter, reason: Failed to connect to Credential Provider


Do you have an idea why we face the issue ?

FYI, we use version : 7.6.5, and we can't upgrade it.

Thanks and Regards,

Laurent

Edited by user Tuesday, August 9, 2016 5:39:11 PM(UTC)  | Reason: Not specified

Offline LaurentCL  
#2 Posted : Wednesday, August 10, 2016 9:52:44 AM(UTC)
LaurentCL

Rank: Free support

Joined: 8/9/2016(UTC)
Posts: 2
France
Location: Paris

Hi,

This is a really blocking issue... @Support : can you please help us ?
Offline Support  
#3 Posted : Wednesday, August 10, 2016 3:10:47 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,273

Thanks: 878 times
Was thanked: 451 time(s) in 428 post(s)
Try rebooting the server. In version 8 we have made some changes to handle "locks" that could happen if someone else logs on to a session (as this might "disturb" the VisualCron implementation). We advise you to upgrade as soon as possible.
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Users browsing this topic
Guest
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Scroll to Top