Issue with the VC API - VisualCron - Forum

Community forum

delcho
2019-02-20T13:45:04Z
Hello, i'm trying to import a settings zip file in VC via the API but the call return false as a result. I'm using version 8.4.1 in trial mode and the TestClient project from the API\sample folder. I have changed the path in the btnImportSettings_Click event to point to my settings file, the client connects successfully to the server but the call returns false. I have enabled debug logging in the settings and the output in the log file is the following:
Quote:


2/20/2019 5:17:13 AM Debug Saving output files and clearing output memory.
2/20/2019 5:17:13 AM Debug Output stored in memory: 0
2/20/2019 5:17:13 AM Debug Calling CleanUp
2/20/2019 5:17:23 AM Debug Loading Conditions
2/20/2019 5:17:23 AM Info Loaded: 14 Condition(s)
2/20/2019 5:17:23 AM Debug Saving Conditions
2/20/2019 5:17:23 AM Debug Saving settings
2/20/2019 5:17:23 AM Debug Server time: 2/20/2019 5:17:23 AM
2/20/2019 5:17:23 AM Info JobAPI->Save->Saving Jobs (44) - in shut down: False
2/20/2019 5:17:23 AM Debug Loading exit codes
2/20/2019 5:17:23 AM Debug Loaded: 1 exit code collection(s)
2/20/2019 5:17:23 AM Err Error occured when importing settings, err: System.NullReferenceException: Object reference not set to an instance of an object.
at VisualCronService.clsCommClientThread.GNJFJLFIHIMMNJJDDIEMAHNCOJDEDNGKLDAI(MessageClass ) in C:\sourcefiles\code\VisualCronService\Connection\clsCommClientThread.vb:line 152
at VisualCronService.clsCommClientThread.NFGCOCNOLLFCIDPMBNANLIOIFJENIMMDOPCO(Byte[] , MessageClass , String , Boolean ) in C:\sourcefiles\code\VisualCronService\Connection\clsCommClientThread.vb:line 105
at VisualCronService.ConnectionAPI.SendToAllDelegate.Invoke(Byte[] row, MessageClass MessageObj, String connId, Boolean bolSynchronized)
at VisualCronService.ConnectionAPI.RaiseSendToAll(MessageClass MessageObj, String connId, Boolean bolSynchronized) in C:\sourcefiles\code\VisualCronService\Connection\apiConnection.vb:line 616
at VisualCronService.ExitCodeAPI.PAIOIGAAJAFKDNECAEECIBBMBBMEMEMJCPEB(ExitCodeClass , ExitCodeClass , String , MessageClass , String ) in C:\sourcefiles\code\VisualCronService\Jobs\ExitCodes\apiExitCode.vb:line 377
at VisualCronService.ExitCodeAPI.Load(String strSpecialPath, Boolean bolSave, Boolean bolCalledFromStart) in C:\sourcefiles\code\VisualCronService\Jobs\ExitCodes\apiExitCode.vb:line 109
at VisualCronService.SettingsAPI.GBDHJGHDCOFGHBPMAHNEDDMCIHHFOJBNKPND(String , ExportImportProgressClass ) in C:\sourcefiles\code\VisualCronService\Settings\apiSettings.vb:line 1125
at VisualCronService.SettingsAPI.ImportSettings(ExportImportProgressClass eip, Boolean bolIsRecovery) in C:\sourcefiles\code\VisualCronService\Settings\apiSettings.vb:line 831



Importing the same file through the UI client works fine. Can you help me with this issue.
Support
2019-02-20T16:06:08Z
Please send settings file and the zipped project in current state to support@visualcron.com
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top