Sharepoint - Upload File and Get Link? - VisualCron - Forum

Community forum

MRomer
2019-08-05T21:37:57Z
Is there a way in VisualCron to get a read-only link for a file in a SharePoint document library? I'm trying to create a job that uploads a large Excel file then emails a link to a customer. I can upload the file just fine, but I haven't found a way to get a link to it. Am I missing something?
Support
2019-08-06T07:21:58Z
Originally Posted by: MRomer 

Is there a way in VisualCron to get a read-only link for a file in a SharePoint document library? I'm trying to create a job that uploads a large Excel file then emails a link to a customer. I can upload the file just fine, but I haven't found a way to get a link to it. Am I missing something?



Moved this to feature request. It's possible that we ask our developers to take a look at this and add the link to the output so you could use it from there.
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
Support
2019-08-27T15:05:03Z
This has now been fixed in this build: https://www.visualcron.c....aspx?g=posts&t=9617 
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
MRomer
2019-08-29T16:37:37Z
Originally Posted by: Support 

This has now been fixed in this build: https://www.visualcron.c....aspx?g=posts&t=9617 


I installed 8.5.5 on my PC and tried an upload. It worked, but I'm having trouble getting a good link back.
My connection is to https://<CompanyName>.sharepoint.com/sites/<SiteName>
In the upload task, I select that connection, and specify the destination folder as Documents.
I successfully uploaded <FileName> using that task and that connection.
The link that comes back is
https://<CompanyName>.sharepoint.com/sites/<SiteName>/sites/<SiteName>/sites/<SiteName>/Documents/<FileName>

when it should be
https://<CompanyName>.sharepoint.com/sites/<SiteName>/Documents/<FileName>

Scroll to Top