Using variables in delete file date field - VisualCron - Forum

Community forum

jbedard
2019-11-05T16:24:10Z
I'd like to set a job variable to a date and use that job variable as a date in the delete files task to delete files older than a specified date. I've tried a few different ways and it keeps failing. Is this possible? Using version 8.5.5.
Support
2019-11-06T08:27:52Z
Originally Posted by: jbedard 

I'd like to set a job variable to a date and use that job variable as a date in the delete files task to delete files older than a specified date. I've tried a few different ways and it keeps failing. Is this possible? Using version 8.5.5.



You should be able to use the date right away or a user variable, however;
We've done some fixes/improvements to exactly that in 9.0.0, so the Date field will show you if you're using the correct format or not (plus it fixes user variable)

I suggest you download our 9.0.0 beta and try it in a test environment and see if you get it working there. It won't be very long now until we release the live version of 9.0.0.

We estimate releasing it in about 1-2 weeks if everything goes as planned.

You can find the beta here. Remember it's not backward-compatible , so if you install it on your current server, make sure to take a backup folder of your current installation folder / take backup of all your settings

https://www.visualcron.c....aspx?g=posts&t=9663 

Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
jbedard
2019-11-06T14:04:50Z
In the delete date field I can use a date value: 10-30-2019 or a date variable: {DATENOWADD(Days,-7,yyyy-MM-dd)}
But when I set a job/user variable {USERVAR(file_date_test)} to a date value and use that variable in the date field, VC crashes.
If this is fixed in 9.0.0, then I think I can wait. Just wondering if this is supposed to be working in 8.5.5, then am I doing something wrong?
Support
2019-11-07T11:08:53Z
Originally Posted by: jbedard 

In the delete date field I can use a date value: 10-30-2019 or a date variable: {DATENOWADD(Days,-7,yyyy-MM-dd)}
But when I set a job/user variable {USERVAR(file_date_test)} to a date value and use that variable in the date field, VC crashes.
If this is fixed in 9.0.0, then I think I can wait. Just wondering if this is supposed to be working in 8.5.5, then am I doing something wrong?



This is something that *should* be fixed in 9.0.0 yes, we would appreciate it if it was possible that you tried it yourself on 9.0.0 to see if it indeed is fixed for you the way you want it or not
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
Scroll to Top