[8.5.5] Bug in variable window - VisualCron - Forum

Community forum

ErikC
  •  ErikC
  • Paid support Topic Starter
2019-11-21T07:04:06Z
Hi,

I found a bug in the variable window.

In the main window, open a task from job A.
From this task, press the Variable button in the bottom left.
Open job B and open the Tasks.
You see alle the tasks from job B ánd the selected task from job A (with a green arrow).

The tasks should only show the tasks from job B.

Regards,
Erik

Uses Visualcron since 2006.
Support
2019-11-21T11:02:01Z
Originally Posted by: ErikC 

Hi,

I found a bug in the variable window.

In the main window, open a task from job A.
From this task, press the Variable button in the bottom left.
Open job B and open the Tasks.
You see alle the tasks from job B ánd the selected task from job A (with a green arrow).

The tasks should only show the tasks from job B.

Regards,
Erik



Hi Erik,

Could you elaborate a little more what you mean, with open, you mean expand or double-clicking? A screenshot or two, to show what you mean would also help

Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
ErikC
  •  ErikC
  • Paid support Topic Starter
2019-11-21T12:37:14Z
Hi Michael,

I might be a bit misteriuos here.. Let me try again:

If you open the variable window from a task, the selected task is shown in every job under the ViasualCron variables.
I hope the picture makes it al more clear.

2019-11-21_13-27-31.png

Regards,
Erik
Uses Visualcron since 2006.
Support
2019-11-21T14:34:18Z
Originally Posted by: ErikC 

Hi Michael,

I might be a bit misteriuos here.. Let me try again:

If you open the variable window from a task, the selected task is shown in every job under the ViasualCron variables.
I hope the picture makes it al more clear.

2019-11-21_13-27-31.png

Regards,
Erik



Hi, thanks. However there seem to be a step between 2 and 3 that i'm missing/not understanding correctly. Probably something simple, but anyway, i recorded a short video clip to show how i tried to replicate it, but i couldn't manage to. Perhaps you can point me to where i'm missing a step/what i should be doing instead?

https://www.screencast.com/t/qPCmrupEg 
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
ErikC
  •  ErikC
  • Paid support Topic Starter
2019-11-21T15:01:03Z
Hi Michael,

in the screencast you opened the Active job in the variable window. You should open a different job, not the active one, not the current job.
In this different job you open up the tasks and then you see a task from the active/current job.

regards
Erik
Uses Visualcron since 2006.
Support
2019-11-21T15:56:25Z
Originally Posted by: ErikC 

Hi Michael,

in the screencast you opened the Active job in the variable window. You should open a different job, not the active one, not the current job.
In this different job you open up the tasks and then you see a task from the active/current job.

regards
Erik



Ah! I get it now, thank you. I have forwarded this to our developers. Thanks for reporting it!
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
Joey S
2019-11-21T15:59:30Z
I didn't try to recreate the issue but I can say that the Variable window does not play nice all the time and the best thing to do is to open the variable window from within each job/task that you are using so the variable window refreshes. Rarely have seen the variable window "update" or refresh after I navigate away from it, even if it is only to open a new/different Job or task window. Unless the variable window is meant to be dynamic like you want it to be, I don't think there is a bug. The methodology I use is to open a job/task then open the variable window and if I open a different job/task after that, I re-open the variable window and everything works fine
ErikC
  •  ErikC
  • Paid support Topic Starter
2019-11-22T08:31:02Z
Originally Posted by: Joey S 

I didn't try to recreate the issue but I can say that the Variable window does not play nice all the time and the best thing to do is to open the variable window from within each job/task that you are using so the variable window refreshes. Rarely have seen the variable window "update" or refresh after I navigate away from it, even if it is only to open a new/different Job or task window. Unless the variable window is meant to be dynamic like you want it to be, I don't think there is a bug. The methodology I use is to open a job/task then open the variable window and if I open a different job/task after that, I re-open the variable window and everything works fine



Hi Joey, the variable window should always show all the current states of the jobs and tasks.
I'm talking about wrong tasks in jobs, so definitely a bug here.

If you experiance different behaviour (the variable window should always show all the current states of the jobs and tasks), please report it.

Regards
Erik
Uses Visualcron since 2006.
Users browsing this topic
Scroll to Top